gs_backup背景信息openGauss部署成功后,在数据库运行的过程中,会遇到各种问题及异常状态。openGauss提供了gs_backup工具帮助openGauss备份、恢复重要数据、显示帮助信息和版本号信息。前提条件可以正常连接openGauss数据库。在进行还原时,需要保证各节点备份目录
创建MOT非常简单。只有MOT中的创建和删除表语句与openGauss中基于磁盘的表的语句不同。SELECT、DML和DDL的所有其他命令的语法对于MOT表和openGauss基于磁盘的表是一样的。创建MOT:create FOREIGN table test(x int) [server mot_
闪回恢复功能是数据库恢复技术的一环,可以有选择性的撤销一个已提交事务的影响,将数据从人为不正确的操作中进行恢复。在采用闪回技术之前,只能通过备份恢复、PITR等手段找回已提交的数据库修改,恢复时长需要数分钟甚至数小时。采用闪回技术后,恢复已提交的数据库修改前的数据,只需要秒级,而且恢复时间和数据库大
支持标准的PostgreSQL创建和删除索引语句。例如:create index text_index1 on test(x) ; 创建一个用于TPC-C的ORDER表,并创建索引:create FOREIGN table bmsql_oorder ( o_w_id intege
新鲜的证书出炉 本月抽空参加Oracle 19c OCP认证考试 两位学员已顺利拿证(oracle考试每个月云贝同学都嗷嗷通过)恭喜云贝的HUANG同学和JIANG同学ocp证书到手啦!点击图片可转跳云贝Oracle 19c OCP试听课https://www.bilibili.com/video/
dba必备技能: 给你一个dmp文件,怎么正确快速的导入到指定的新库新用户下? 比如目标库给你了:要求将提供的dmp,导入到新库的test用户和testtbs表空间下。 你需要了解的信息: 1.源端字符集和目标字符集是否匹配?–否则导入也可能是乱码。 2.dmp是expdp还是exp的?–才知道导入
修改库字符集 ALTER DATABASE ods_a6 DEFAULT CHARACTER SET utf8mb4 DEFAULT COLLATE utf8mb4_bin; 修改表字符集 ALTER TABLE nacos.config_info DEFAULT CHARSET=utf8mb4 C
特别强调~ 本测试使用的是MySQL 8.0.27~ 8.0.27~ 8.0.27(因为不同版本命令可能会有差异哈) 打开两个终端,分别连接上MySQL,使用select @@global.transaction_isolation;查看隔离级别(间隙锁要在可重复读的隔离级别下) 如果报类似ERR
注意: 预计MOT将针对这一场景进行多项额外的甚至重大的性能改进。更多关于大规模数据流和数据采集的信息,请参阅MOT应用场景。
硬件要求编译openGauss的硬件要求:机器数量:1台机器硬件规格:CPU:4U(64位)Memory:8GFree Disk:100G软件要求操作系统要求openGauss支持的操作系统(Linux 64位):CentOS 7.6(x86_64 架构)openEuler-20.03-LTS(aa
如果所使用的系统为 openEuler 22.03 以上的版本,可以直接使用 yum 安装 A-FOT 工具及其依赖的工具 autofdo:yum install -y autofdo a-fot 如果不是,则按照如下步骤安装 autofdo 以及 A-FOT首先需要安装 autofdo,在安装之前
一、主备双集群部署架构:主集群:一主一备;灾备集群:一主一备1. 安装集群 1主节点:192.168.0.141 备节点:192.168.0.145xml 文件参考:
一、数据库集群未安装的场景下配置 VIP1. 添加 vipifconfig eth0:26000 192.168.0.10 netmask 255.255.255.0 up 2. ifconfig 提权修改权限文件/etc/sudoers,添加以下内容,为集群用户添加 ifconfig 权限。# e
一、 功能说明只读状态从数据库获取,保证准确性; 只读仲裁只仲裁当前超过阈值的实例,其他节点不受影响; 主机只读保护后自动主备切换,选可用备机升主保证集群能正常提供工作。二、 相关参数设置设置数据库只读模式的磁盘占用阈值为 95%$cm_ctl set --param --server -k dat
Mogdb 备机处于 standby need-repair 状态怎么处理?背景介绍:Mogdb 主备环境,备机检查发现 Standby Need repair 故障。报错原因:因网络故障、磁盘满等原因造成主备实例连接断开,主备日志不同步,导致数据库集群在启动时异常。主备状态检查:[root@hos
随着数据库技术的不断发展,分区表已经成为数据库系统中不可或缺的一部分。openGauss 作为国产数据库的佼佼者,值得我们去研究一下。 在此恭喜 openGauss 在 2023年7月中国数据库排行榜中荣升第二。openGauss 5.0.0是openGauss发布的第三个LTS版本,该版本生命周期
概述在使用官网提供的镜像安装数据库,有时会遇到一些 "非法指令" "illegal instruction" 的问题,或者在一些本地搭建的虚拟机上,数据库启动失败,但是没有很明确的错误信息的问题。 这些往往是由于 CPU 指令集不兼容导致的。常见的有 3 种:arm CPU 下的 lse 指令x86
概述在部分系统中,使用 OM 安装完成 openGauss 数据库后,会出现例如 yum install 不可用, 或者 ssh 不可用的问题。问题现象在 openeuler20.03 系统上,使用 openGauss 3.0.3 之前的版本,OM 安装完成后,切换到 root 下使用 yum 安装
1.简介与 Mysql 的 Performance_schema 类似,openGauss 本身也提供类似的性能监控视图。但与 Mysql 也存在差异,本文就针对两者异同做个比较。Mysql 的性能监控视图保存在 performance_schema schema 下,openGauss 主要保存在
背景介绍:PTK (Provisioning Toolkit)是一款针对 MogDB 数据库开发的软件安装和运维工具,旨在帮助用户更便捷地安装部署 MogDB 数据库。如果用户想要运行 MogDB 或者 MogDB 的相关组件时,仅需要执行一行命令即可实现。PTK 支持安装 MogDB 的操作系统众