前言随着MySQL版本的发展,优化器是越来越智能,优化器开关也越来越多,本文给大家分享一下MySQL对derived table的优化处理。何为derived table?这里我把它翻译成派生表,简单来讲,就是将from 子句中出现的检索结果集当做一张表,比如from 一个select构造的子查询,
前文回顾实现一个简单的Database1(译文)实现一个简单的Database2(译文)实现一个简单的Database3(译文)实现一个简单的Database4(译文)实现一个简单的Database5(译文)实现一个简单的Database6(译文)实现一个简单的Database7(译文)实现一个简单
安装简介高可用搭建高可用及负载均衡测试问题处理一、安装简介1.1 安装目的MySQL官方提供了InnoDB Cluster,该集群由MySQL MGR和MySQL Router组成。MySQL MGR在数据库层面实现自主高可用性,而MySQL Router则负责代理访问。在部署完成后,MySQL R
往期回顾图文结合带你搞定MySQL日志之Undo log(回滚日志)图文结合带你搞懂InnoDB MVCC图文结合带你搞懂MySQL日志之Redo Log(重做日志)图文结合带你搞懂MySQL日志之Error Log(错误日志)图文结合带你搞懂MySQL日志之Slow Query Log(慢查询日志
作者简介:高鹏,笔名八怪。《深入理解MySQL主从原理》图书作者,同时运营个人公众号“MySQL学习”,持续分享遇到的有趣case以及代码解析!关注这个问题主要是怕使用mysqldump升级的时候,因为做跨版本升级我一般任何业务库的数据导出导入是最稳当的。如果表的字符集遇到问题,这是一个比较严重的问
1.新增特性1.1 SQL兼容性 1.2 MGR 1.3 性能优化 1.4 安全2.稳定性提升3.其他调整4.bug修复5.GreatSQL VS MySQL6.GreatSQL Release NotesGreatSQL 8.0.32-24版本发布,增加并行load data、(逻辑 &
GreatSQL删除分区慢的跟踪背景某业务系统,每天凌晨会删除分区表的一个分区(按天分区),耗时较久,从最开始的30秒,慢慢变为1分钟+,影响到交易业务的正常进行。 在测试环境进行了模拟,复现了删除分区慢的情况,本次基于GreatSQL8.0.25-17进行测试,官方mysql版本也存在相同问题。测
作者简介:高鹏,笔名八怪。《深入理解MySQL主从原理》图书作者,同时运营个人公众号“MySQL学习”,持续分享遇到的有趣case以及代码解析!仅仅作为自己的学习笔记,不做其他用途。原文中有大图,参考https://www.jianshu.com/p/d27f46975453一、恢复的主要阶段实际上
芬达,《芬达的数据库学习笔记》公众号作者,开源爱好者,擅长 MySQL、ansible。背景openEuler 是什么openEuler22.03 LTS 是 openEuler 社区于 2022 年 3 月发布的开源操作系统(从系统版本的命名不难发现吧)。openEuler 社区的运营由华为为主导
前言Instant add or drop column的主线逻辑表定义的列顺序与row 存储列顺序阐述引入row版本的必要性数据腐化问题原因分析Bug重现与解析MySQL8.0.30修复方案前言DDL 相对于数据库的 DML 之类的其他操作,相对来说是比较耗时、相对重型的操作; 因此对业务的影比较
Code as Standrad 这个名词是我发明的,为了减少对部署规范文档的依赖,使用 playbook 编码的方式固定部署规范, 使用 dbops 部署即视为满足交维规范。dbops是什么?dbops 是一堆高效的 ansible playbook 的集合,目前是一个自动化安装部署生产级别的 M
背景五一期间,我用前端三件套写一个自用的浏览器插件,后端程序用 nodejs,它会连接 MySQL8.0.33 数据库,3306 端口。这个数据库是跑在我的 vmware 虚拟机里的,它同时是我的实验环境,上面还利用多实例部署方式,跑了另外一个 MySQL5.7.39 的实例,运行在 3307 端口
背景昨天我研读了源码大佬八怪的新文章《MySQL:主从 HASH SCAN 算法可能导致从库数据错误》,我将其内容概括如下:如果主从复制的行搜索算法设置为使用 HASH SCAN,从库数据可能会与主库不同,导致从库直接抛出复制异常。结合文章细节,我再补充一些理解:这个问题只在 MySQL8.0 中出
关联文章:MySQL对derived table的优化处理与使用限制一、Bug描述同事遇到一个有意思的语句,说一条SQL在MySQL8.0.25版本运行出的结果明显与给定的where条件不符,而在8.0.26版本上是正常的,语句上加了一个无关的用户变量后在8.0.25版本上结果才是正确的,想不通这是
往期系列回顾图文结合系列之带你搞懂MySQL日志系列很多小伙伴使用了GreatSQL,但是对GreatSQL的底层原理还不是很了解,今天就带大家一起揭开GreatSQL体系架构的神秘面纱!首先来回顾一张经典的体系架构图:图1_GreatSQL5.7 版本体系架构图由此可以发现,GreatSQL5.7
作者简介:高鹏,笔名八怪。《深入理解MySQL主从原理》图书作者,同时运营个人公众号“MySQL学习”,持续分享遇到的有趣case以及代码解析!一、问题来源这是今天的一个问题,是朋友杨长江给我的,版本MySQL 5.7.17。问题为show slave status遇到了大量的空洞,如下:这里只是部
当前,全球数字经济加速发展,数据正在成为重组全球要素资源、重塑全球经济结构、改变全球竞争格局的关键力量。数据库作为存储与处理数据的关键技术,在数字经济浪潮下,不断涌现新技术、新业态、新模式。7月4-5日,由中国通信标准化协会和中国信息通信研究院主办,大数据技术标准推进委员会承办,InfoQ联合主办的
GIPKs特性简介GIPKs特性的作用玩转GIPKsGIPKs解决了历史难题1. GIPKs特性简介从MySQL 8.0.30开始,新引入一个叫做GPIKs的特性,其全称是 Generated Invisible Primary Keys,简言之就是 自动生成隐含的主键列,更完整的说法是:启用GIP
提问的艺术_GreatSQL社区如果你正想提问题,那不妨先看看这篇文章~可以帮助提高你的发问技巧,获取你想要的答案。有些人不愿意思考,或者在发出问题前不愿意做应该完成的事情,这些人只会浪费我们的时间,从不想着付出,而我们本可以把时间用在更有趣的问题或者更值得回答的人身上。提问之前在社区提问或者在群里
背景概述在一次客户的数据库实例连接不上了,需要我们排查一下原因,通过查看数据库实例进程已经不存在了,在错误日志中没有发现其他报错信息,发现有shutdown的字样出现,怀疑是某个用户手动关闭了实例。我们通过以下测试,发现是由于用户关闭了主机所导致的。问题复现本次测试基于GreatSQL 8.0.32